Alaska 4x4 Network

Go Back   Alaska 4x4 Network > Alaska 4x4 Network Forums > 4x4 Vehicle (car, truck, etc)

Reply
 
Thread Tools Display Modes
Old 10-25-2017, 08:59 AM   #1
Dan2e
Registered Member
 
Join Date: Oct 2017
Posts: 1
Dan2e has disabled reputation
Question Electrical issues 1988 Chevy k1500

So I recently picked up a lifted stepside short box and discovered that I had no taillights, high beams, or dash lights! Iíve checked the fuses checked the bulbs and the relays and now Iím stumped! I should also state that the arm/multi function switch that controls wipers and light selection seems loose would a broken arm cause this issue?
Dan2e is offline   Reply With Quote
Old 10-30-2017, 07:23 PM   #2
wasillashack
Registered Member
 
Join Date: Apr 2008
Location: Wasilla
Posts: 4,416
wasillashack has disabled reputation
Default Re: Electrical issues 1988 Chevy k1500

I usually look for obvious issues like electrical tape, splices or broken/missing components. In your case the broken lever may be a indicator of a deeper problem, I'd look there first. Good luck!
__________________
Any man who thinks he can be happy and prosperous by letting the government take care of him had better take a closer look at the American Indian.Ē
~ Henry Ford

We are told not to judge Muslims based on the actions of a few.

I suggest we give the millions of responsible Americans gun owners that same courtesy.
wasillashack is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -9. The time now is 06:41 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Copyright Alaska 4x4 Network